Excel- Summarise and Analyse Data with Pivot Tables

Pivot Tables are one of Excel’s best features. You can use a Pivot Table to summarise and analyse data. It is
particularly useful if you work with large amounts of data and need a quick, flexible way to produce reports
from it.

Make sure your data is well laid-out

In order to create a Pivot Table successfully, just follow a few golden rules:

— Your data should be arranged in columns and rows. A C B c b) E
1 |First Name _Last Name  Salary Age Gender

— Each column should contain a descriptive heading. 2 |Stephanie  Corbett £125,000 32|Female
3 Diane Ford £37,500 25 Female
4 |Rose Kirby £25,000 26 Female
5 |Frances Holt £70,313 38 Female
6 |Anne Beager £21,875 31 Female

(“1 Although not essential, it’s good practice to apply
(=] formatting, e.g. bold to the column headings.
— Avoid empty rows or columns within the data (an occasional empty cell is OK).

— Turning your data into an Excel Table will make it easier to add or remove rows and columns in your
data without having to redefine the data range of the Pivot Table.
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o  Click a cell within your block of data. %
o  Press CTRL + T on the keyboard, or click the Insert tab on the ribbon and click e atToes s
Table. e

(“1 Use the Table Tools on the ribbon to apply a Table Style to your data.
g

Create the Pivot Table

1. Click the Insert tab HOME  INSERT

B B

2. Click Pivot Table on the ribbon or press Alt + N+V or click Recommended Pivot protaiehecommendes Tt
Tables 5 astes

Choose the information to display in the Pivot Table

Excel creates the pivot table and places a set of Pivot table Tools on the ribbon. Use these to work with
your pivot table.

Excel also displays the Pivot Table Fields area at the right-hand side of the screen. This is where you can
construct the pivot table and decide on its layout.

The pivot table includes totals by default, but you can choose whether to include these or not- Use the
Grand Totals button in the Layout section of the Design tab of the PivotTable Tools.
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Design the pivot table

Designing your pivot table is as simple as dragging fields from the field list to the field areas. As you do,
Excel builds the pivot table on the worksheet so you can see how the data will look.
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1 [Status (all) - PivotTable Fields vooX
2 Choose fields to add to report:
3 |sum of Salary Column Labels |~ I

4 |Row Labels - DIST ESTATES  FINANCE HR STORES  TPT Grand Total [Search 0|
5 |Assistant £360,000 £342,000 £846,000 £1,025,000 £378,000 £90,000 £3,042,000

6 |Asst. Manager £595,000  £420,000  £490,000 £175,000 £1,680,000 [ Full Name a
7 |co-ordinator £100,000 £600,000 £275,000 £500,000 £200,000 £1,675,000

8 |Director £50,000  £50,000 £100,000 Dest

9 |Manager £160,000 £280,000 £400,000 £840,000 £560,000 £80,000 £2,320,000 Job Title

10 | Managing Director £80,000 £80,000 O Leve

11 |Operative £128,000  £560,000 £944,000 £96,000 £1,728,000 sary
12 Supervisor £242,000  £285,000  £228,000 £313,500 £171,000 £1,335,500
13 Grand Total £1,000,000 £2,662,000 £2,209,000 £2,006,000 £2,195,500 £812,000 £11,964,500 Do cyment Date
. = Birthdate .
: A
16 Drag fields between areas below:
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19 Status ~ || Dept ~
20
2
2
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24 Job Title | |[ Sum of Salary ~
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See your data in a different way

Pivot Tables are extremely flexible so if you want to change how your data is arranged, just click and drag
the fields from one area of the field list pane to another. Excel will rebuild the pivot table and rearrange
the data.

If you no longer want a field as part of the pivot table, drag it out of the field list area until you Dept
see a cross attached to your mouse then release the mouse button, or click the tick against the T%X
field name in the Field List at the right of the widow to deselect it.
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5 |Asst. Manager £1,680,000
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7 |Director £100,000 Status
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Change the calculation used to summarise your data

1. Right-click a summarised value in the pivot table.

2. Choose Summarize Values By from the shortcut menu to display a
list of available functions.

3. Click the function you want to use to recalculate your data.

Note: by default Excel summarises numeric fields in pivot tables by Sum
and text data by Count.

Refresh the pivot table

Sum
Count
v Average
Summarize Values By 3 L\)
Max

Min

Show Values As 3

Show Details
Product

More Options...

If you change any of the source data for your pivot table, the pivot table will not recalculate automatically.
To reflect any changes you have made to the source data, you must refresh the pivot

table.

1. Make changes in the source data.

2. Click into the pivot table.

3. Right-click any cell in the pivot table, and choose Refresh from the shortcut menu. D

By Copy

E Format Cells...
Number Format...

ré Refresh

Sort 3

Alternatively, click the Refresh button on the Analyze tab of the PivotTable Tools on the i

ribbon.

Format the Pivot Table

(5
Refresh

— Use the Tools on the Design tab to choose the look for the whole pivot table

— Right-click a value in the pivot table and choose Number Format... from the shortcut Ba Copy
menu to select the number format you want.

— Right-click text in the pivot table and choose Foramt Cells... from the shortcut menu to
set the text format you want.

Drill down into a summarised value to view details

1. Double-click a summarised value in the pivot table.

Eormat Cells...

Mumber Format...

[Z Refresh

2. Excel creates a new sheet and places all the items that make up the summarised value into separate

rows.

A B

c D

E

1 Details for Sum of Salary - Job Title: Assistant, Status: Contractor (+)

4 498 Nancy Bailey Bailey, Nancy Full-Time HR Assistant  ADM 18000 24/10/2017 11/03/1971 54
5 497 Arthur Flores Flares, Arthur Full-Time FINANCE Assistant ADM 18000 09/12/2006 24/02/1394 31
6 495 Amy Hughes Hughes, Amy Temporary FINANCE Assistant  ADM 18000 35/02/2017 _01/03/1975 50
7 493 Kathy ward Ward, Kathy Part-Time  DIST Assistant  ADM 18000 25/08/2009 10/05/1968 57
8 5 Anne Beager Beager, Anne Full-Time DIST Assistant  ADM 18000 14/11/2008 12/12/1993 32
9 482 Timothy Price Price, Timothy Full-Time HR Assistant  ADM 18000 15/06/2005 15/01/1986 39
10 481 Kimberly Anderson Anderson, Kimberly  Temporary HR Assistant  ADM 18000 05/08/2013 19/11/1998 27
1 480 Elizabeth  Diaz Diaz, Elizabeth Temporary HR Assistant  ADM 18000 02/03/2013 12/02/1389 36
12 9 Gloria Brown Brown, Gloria Full-Time HR Assistant _ ADM 18000 17/04/2008 _13/03/1987 38
13 479 Andrew Russell Russell, Andrew Full-Time FINANCE Assistant _ADM 18000 07/05/2016 _30/12/1969 56
14 478 Paula Ramirez Ramirez, Paula Temporary ESTATES Assistant ADM 18000 18/04/2015 05/11/1974 51
15 477 Lois Lee Lee, Lois Full-Time STORES Assistant ADM 18000 25/02/1996 20/07/1989 36,
16 476 willie Barnes Barnes, Willie Temporary DIST Assistant _ ADM 18000 25/05/2013 30/10/1994 31,
17 475 sandra Long Long, Sandra Temporary TPT Assistant  ADM 18000 25/10/2001 18/03/1989 36
18 457 Teresa Baker Baker, Teresa Temporary HR Assistant  ADM 18000 02/09/1996 18/11/1393 32
15 16 Violet Squires Squires, Violet Temporary HR Assistant _ ADM 18000 01/03/2002_01/09/1992 33
20 463 Ruth Taylor Taylor, Ruth Full-Time HR Assistant  ADM 18000 02/11/2012 07/02/1966 59
21 18 Wanda Frost Frost, Wanda Part-Time ESTATES Assistant ADM 18000 16/07/2002 14/09/1998 27
2 19 Ellen Lock Lock, Ellen Full-Time ESTATES Assistant ADM 18000 23/09/2015  23/04/1973 52
23 461 Irene Bell Bell, Irene Temporary HR Assistant  ADM 18000 24/04/1999 05/03/1965 60
u 458 Marie Moore Moore, Marie Full-Time STORES Assistant ADM 18000 25/10/1995 31/12/1973 52
25 457 Roger Johnson Johnson, Roger Full-Time STORES _Assistant ADM 18000 05/11/2012 05/11/1380 45
2% 452 Marilyn Hernandez _Hemandez, Marilyn _ Temporary FINANCE Assistant ADM 18000 21/09/201230/01/1994 31
27 451 Lois Martin Martin, Lois Full-Time HR Assistant ADM 18000 05/05/2012 02/11/1579 46
28 450 Robert Bailey Bailey, Robert Part-Time FINANCE Assistant ADM 18000 16/06/1996 16/09/1967 58|
< > Detaill  speett Course List | Training + ;4 —

Note: the data on the new sheet
is static, so won’t reflect any
later changes.



Filter a pivot table

You can filter the data in a pibot table in several ways:

— Drag a field to the Filter area of the pivot table
— Filter the Row labels and/or Column labels

— Use the Filter arrows to choose the data to display

A B C D E F G H |
1 [status (All} B
2
3 |Sum of Salary Column Label
4 Row Labels IST ESTATES FINANCE HR STORES TPT Grand Total
5 |Assistant £360,000 £342,000 £846,000 £1,026,000 £378,000 £90,000 £3,042,000
6 |Asst. Manager £595,000 £420,000 £490,000 £175,000 £1,680,000
7 |Co-ordinator £100,000 £600,000 £275,000 £500,000 £200,000 £1,675,000
8 Director £50,000 £50,000 £100,000
S Manager £160,000 £280,000 £400,000 £840,000 £560,000 £80,000 £2,320,000
10 |Managing Director £20,000 £20,000
11 |Operative £128,000 £560,000 £944,000 £96,000 £1,728,000
12 |Supervisor £342,000 £285,000 £228.000 £313,500 £171,000 £1,3359,500
13 Grand Total £1,000,000 £2,662,000 £2,299,000 £2,906,000 £2,195,500 £812,000 £11,964,500
14

Status é

Contractor
Full-Time
Part-Time

Temporary

Group data in a pivot table

Sometimes you may want to group data instead of seeing it in distinct rows or columns. This is particularly
useful for dates. Excel can group dates automatically but you can also group data manually:

— Click and drag the items you want to group

— Right-click an item and click Group... from the shortcut menu. Depending on the data type, you may see
extra options, eg for dates you can can choose Years, Quarters, Months etc

| A B C D E F G H |
1 |Status (All) -
2
3 |Sum of Salary Column Labels -
4 |Row Labels ~ |Di1sT ESTATES FINANCE [HR STORES  TPT Grand Total
5 |Assistant £360,000 £342,000 £846,000(8 [y copy D42,000
6 |Asst. Manager £595,000 £420,000 80,000
7 |co-ordinatar £100,000 £600,000 £275,000 Format Cells.. 75,000
& |Director £50,000| | [ Refresh 100,000
9 |Manager £160,000 £280,000 £400,000( | _ : 20,000
10 |Managing Director £80,000| | L Delete PivotTable £30,000
11 |Operative £128,000 £560,000 ot 5 28,000
12 |supervisor £342,000 £285,000 £228,000 - 35,500
13 | Grand Total £1,090,000 £2,662,000 £2,299,000] £ Filter > 364,500
14 ~" Subtotal "Dept"
15
16 Expand/Collapse >
;
18 L
19 @l Ungroup...
20 Move >

[
iy


https://www.abdn.ac.uk/toolkit/documents/uploads/excel-slicers.pdf

A new column appears in the pivot table for the group total and a new group heading appears in the coumn

or row area, depending on how you’ve grouped the data.

Note: Excel uses generic names for any groups you create eg Group 1, but you can change this by selecting

the heading and overtyping with your own choice of title.

| A
1 |Status
2
3 Sum of Salary
4
5 Row Labels
6 |Assistant
7 |Asst. Manager
8 |Co-ordinator
9 |Director
10 |Manager

B
{all) -

=IGroupl
- | DIST
£360,000

£100,000

£160,000

11 |Managing Director

12 | Operative
13 |Supervisor
14 |Grand Total

£128,000
£342,000

ESTATES
£342,000
£595,000
£600,000

£280,000

£560,000
£285,000

£1,090,000 £2,662,000 £2,299,000!

D E
o
Groupl Total
FINANCE
£846,0000  £1,548,000
£420,000 £1,015,000_|I
£275,000 £975,000
£50,000) £50,000
£400,000 £840,000
£30,000 £80,000
£688,000
£228,000 £855,000
\£6,051,000)

Once created, you can collapse/expand the group to display the level of detail you require

— Click the outline symbol (- or +) alongside the Group label

| A

1 |Status

2

3 Sum of Salary
a

5 Row Labels
6 |Assistant

7 | Asst. Manager
8 |Co-ordinator
9 |Director

10 |Manager

11 |Managing Director

12 |Operative
13 |Supervisor
14 Grand Total

B = D E
(All = G

Jlumn Labels ~ ——

roupl Groupl Total

~ | DIST ESTATES FINANCE

£360,000 £342,000 £346,000f £1,548,000
£595,000  £420,000] £1,015,000.|I

£100,000 £600,000 £275,000) £975,000

£50,0004 £50,000

£160,000 £280,000  £400,000 £340,000

£80,0004 £80,000

£128,000 £560,000 £688,000

£342,000 £285,000 £228,000 £855,000
£1,090,000 £2,662,000 £2,299,000  £6,051,000 )

Further information and help

1 Status

2

3 Sum of Salary
4|

5 Row Labels hd
6 |Assistant

7 |Asst. Manager

8 |Co-ordinator

9 |Director

10 |Manager

11 |Managing Director
12 |Operative

13 |Supervisor

14 |Grand Total

Lolumn Labels ~
hroupl

£1,548,000

£1,015,000

£975,000

£50,000

£840,000

£80,000

£688,000

£855,000

£6,051,000

(All) -
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